unable to run plugin

unable to run plugin

Postby mark_l » Wed Aug 29, 2018 5:43 pm

I've got linux 16.10 and xplane 11.25

after putting the plugin in the plugin folder and starting xplane, the pilotedge plugin does not appear in the dropdown list

this appears in the xplane log.txt:


dlerror:libpng12.so.0: cannot open shared object file: No such file or directory
dlerror:/home/mark/X-Plane 11/Resources/plugins/PilotEdge/lin.xpl: wrong ELF class: ELFCLASS32
mark_l
 
Posts: 1
Joined: Wed Aug 29, 2018 5:33 pm

Re: unable to run plugin

Postby Keith Smith » Thu Aug 30, 2018 9:00 am

Answered via tech support, but will answer here in case others might have the issue.

Your system is missing a required library (libpng12). Google that term and you'll see many links for where to obtain the library.

The second error can be ignored...that's xplane attempting to load the a version of the plugin from a legacy location having failed to load it from the preferred 64-bit location. The version that it's finding in the legacy location is the 32-bit version of the plugin, hence the error message. Fixing the first error will allow the 64-bit plugin to load, after which it won't attempt to load from the legacy location at all.
Keith Smith
 
Posts: 9314
Joined: Sat Oct 09, 2010 8:38 pm
Location: Pompton Plains, NJ


Return to X-Plane

Who is online

Users browsing this forum: No registered users and 3 guests