Page 1 of 1

Mic not working on Imac with USB headset

PostPosted: Mon Dec 07, 2020 11:11 am
by topilot
The audible announcement says I am connected without any issue warnings, but my headset mic does not seem to work when I do the test. I do not hear a click when I push the assigned ATC contact keystroke. Can you tell me what the problem is? I am using Catalina OS on a 27" iMac and have no problems running X-Plane 11. I am a new user of PilotEdge so I walked through your instructions and searched the forums but still do not see a solution. I hear the audio but no mic response. Most of your postings are for Windows users.

Re: Mic not working on Imac with USB headset

PostPosted: Mon Dec 07, 2020 1:47 pm
by Kevin_atc
What model of headset are you using?
Does your headset show up in the pilotedge plugin preferences as an input device? (I believe that feature is still on the Mac OS build)

Re: Mic not working on Imac with USB headset

PostPosted: Mon Dec 07, 2020 3:25 pm
by Keith Smith
There is no 'click' associated with pressing the PTT key, so that is not an audio queue to use.

Instead, per the installation video on the xplane page, I'd recommend listening to an ATIS at a supported towered airport, ensuring that it is indeed the PE ATIS you're hearing and not the in-game ATIS. You can tell because when you disconnect from PE, that ATIS will stop.

Once you've establishing you're hearing the ATIS, hold the PTT for a second or two and take note of whether the ATIS cuts out or not. If the ATIS keeps playing while the PTT is depressed, then the PTT isn't firing. If it does cut out, then the PTT is firing.