Page 2 of 2

Re: Saitek Radio Panel with X-Plane

PostPosted: Fri Oct 21, 2011 1:30 pm
by Nick Adams
Steven,

I have the one for my mac from Tom Sedge that was released a couple years ago. Is there a difference b/w the one I have and the new one?

Re: Saitek Radio Panel with X-Plane

PostPosted: Fri Oct 21, 2011 1:33 pm
by Steven Winslow
Yes, Nick, there is a new one on the org. It adds DME functionality and changes the way the transponder works, too. The link I posted is for the new one. I've tried it and I have a friend that swears by it. I'll give it another go this weekend.

Re: Saitek Radio Panel with X-Plane

PostPosted: Wed Feb 12, 2020 1:46 pm
by mikedomanski
Who has the old copy of the Saiteck MAC drivers they can send me for the radio panel?

ever since logitech took them over all links point to windows only and mac support is no more. i tried the forums.x-plane.org but the entire site returns an error: Error 522 Ray ID: 564165066e14d531 • 2020-02-12 20:43:24 UTC
Connection timed out

Re: Saitek Radio Panel with X-Plane

PostPosted: Wed Feb 12, 2020 10:22 pm
by FDXDave
I use the radio panel with the above mentioned plugin. You may read about cfg files required for saitek panels. You do not need anything other than the plugin for it to work. In between flight's you may need to unplug and replug in the radio panel, due to usb drivers and windows usb power management. I just am in the habit of plugging it in before i run XP11.
Xp11. With win 10 pro here.
Dave

Re: Saitek Radio Panel with X-Plane

PostPosted: Thu Feb 13, 2020 6:41 am
by Keith Smith
Dave, he's running it on MacOS, not sure it'll work the same, driver-wise.

Re: Saitek Radio Panel with X-Plane

PostPosted: Thu Feb 13, 2020 10:07 am
by FDXDave
Keith Smith wrote:Dave, he's running it on MacOS, not sure it'll work the same, driver-wise.


Oh... i missed that part.

Re: Saitek Radio Panel with X-Plane

PostPosted: Thu Feb 13, 2020 12:43 pm
by Vincent Meier

Re: Saitek Radio Panel with X-Plane

PostPosted: Thu Feb 13, 2020 3:25 pm
by Keith Smith
thx Vince, I think the .org forums were down for a little while (including at the time he posted).