Comm issue

Discussions surrounding the software that lets pilots connect to PilotEdge and the actual simulators

Comm issue

Postby Vaillant » Sat Sep 09, 2017 9:09 pm

I have the weirdest issue.
I'm using P3D V4 and everything was working fine before but today I cannot talk on PilotEdge.
Somehow my PTT is not working I defined a key in FSUIPC when pressing (and holding) a button on my yoke. The button doesn't seem to be doing anything. At the bottom right of my PilotEdge client window I have all the time (even with button not pressed) the message Transmitting on : FREQ [voice] with FREQ being whatever frequency I tune in my airplane.
I can hear the controller fine but whenever I speak nobody hear me and the transmitting message never change.

I tried changing the key, to default scroll lock, nothing changed except for the P3D atc window coming in and out, confirming the button and key shortcut are working fines. My microphone works as well as FS2Crew was picking up everything.

Per Keith's advice I removed the key and setup the button as PTT on and off (upon release) in FSUIPC but the only things it did was logging me in and out of PilotEdge network.

I really don't know what to do. I rebooted my computer, removed the PilotEdge folder and reinstalled the client without success. I cannot use the network right now :?: :(
Posts: 21
Joined: Tue Jul 14, 2015 12:46 pm

Re: Comm issue

Postby Shawn Goldsworthy » Sat Sep 09, 2017 9:22 pm

Something for you to try. If you run P3D as an administrator, make sure you run the Pilotedge client as administrator as well. This is a known issue that occurs when one is run as admin and the other isn't, the PTT just doesn't work. Give that a try and let us know if it works for you.

Under the configuration header on the client download page, it says this:

1. If you run FS2004/FSX/P3D as Administrator, you must also run PilotEdge as Administrator, otherwise the keyboard-based Push To Talk will not function reliably.
Shawn Goldsworthy
PilotEdge ATCS
Shawn Goldsworthy
Posts: 428
Joined: Sun Nov 07, 2010 9:23 pm
Location: Nova Scotia, Canada

Re: Comm issue

Postby Vaillant » Sat Sep 09, 2017 10:25 pm

Thank you for the super fast help!

It did do the trick. My message at the bottom right didn't change but when I did radio check I got a loud and clear right away ;) ;)

Thanks again, the issue is solved.
Posts: 21
Joined: Tue Jul 14, 2015 12:46 pm

Re: P3D v4 Comm issue

Postby dhplane » Sat May 12, 2018 2:50 pm

I recently migrated from FSX to P3D v4 and I’m having essentially the same problem... I can hear the controller but cannot get anybody to hear me. I have tried everything I can think of and many of the things I read in the forum, including running everything as administrator.

Windows 10 sees the headset and microphone, as well as the P3D Sound tab. The Pilotedge Options/Voice page shows the headset as the output device but not as input... it only displays a generic device as input choice.

Part of the difficulty in troubleshooting this is that the old Pilotedge window (Tx, Rx, Ident) made it possible to see if I was actually transmitting when I pressed the PTT button, but the new client doesn’t provide that kind of feedback.

Any ideas on how to fix this would be appreciated because I am unable to use the network.


Posts: 44
Joined: Sun Dec 13, 2015 9:06 am

Return to Flight Simulators and PE clients

Who is online

Users browsing this forum: No registered users and 2 guests