Page 1 of 1

MSFS 2020 and PE Comms

PostPosted: Thu Sep 10, 2020 6:56 am
by Williamsg08
I can connect to PE - and I know this because my plane shows up on the PE "Live Map" but I can't hear or speak to ATC (I've checked the frequencies, I've made sure the batt/alt is on, I've made sure the volume was up etc.). I have no issues with xplane and PE & Vatsim or with MSFS 2020 and Vatsim - I just can't get MSFS and PE voice to work. I have to be overlooking something and/or something is conflicting in the set up? Any ideas?

Re: MSFS 2020 and PE Comms

PostPosted: Thu Sep 10, 2020 8:13 am
by Kevin_atc
Have you verified your audio devices are correct? Make sure they’re plugged in before your fire up the simulator.
For more real time tech support, swing by our discord. www.pilotedge.net/discord

Re: MSFS 2020 and PE Comms

PostPosted: Mon Sep 21, 2020 9:05 am
by dpaget21
I have having the same issue, were you able to fix this? I open the PE app and have headset and push to talk operating correctly then launch the sim, start flight (off ramp) connect PE console all with no errors but I am not able to hear or talk to anyone. Any ideas?

Re: MSFS 2020 and PE Comms

PostPosted: Mon Sep 21, 2020 6:33 pm
by Kevin_atc
dpaget21 wrote:I have having the same issue, were you able to fix this? I open the PE app and have headset and push to talk operating correctly then launch the sim, start flight (off ramp) connect PE console all with no errors but I am not able to hear or talk to anyone. Any ideas?


I’ll refer you to my response to the OP. Check those audio devices and then swing by Discord where we can help you much faster.