Sending ATC audio to the headset

Discussions surrounding the software that lets pilots connect to PilotEdge and the actual simulators

Re: Sending ATC audio to the headset

Postby BonanzaDude » Wed Dec 11, 2013 6:20 pm

Sorry to bring up an old topic, but If I am reading this correctly, I have to do these steps before every PE flight?

I had my PE client on a remote laptop but I was having issues talking with Ventrilo and TS friends and having my transmissions going out over the VATSIM frequency. I couldn't find a solution for that so I moved the USB headset/mic combo over to the FSX computer.

John
John P. Navara
zLAARTCC & PE I-11
PP ASEL-IA - 1967 V35 N480H
Complex, HP & Tailwheel endorsements
My YouTube Videos
http://www.twitch.tv/Sim_Dude
BonanzaDude
 
Posts: 202
Joined: Wed Jun 22, 2011 1:29 pm
Location: Tiffin, IA

Re: Sending ATC audio to the headset

Postby Keith Smith » Thu Dec 12, 2013 2:44 pm

John,

PE uses the default sound device on your computer when it starts up, that hasn't changed. Therefore, if you set your FSX output device to be your speakers (one time step), then just set your default playback device to be your headset prior to starting PE each time, then you should be good to go.

Regarding the remote machine, it sounds like you had overlapping PTT assignments.
Keith Smith
 
Posts: 9332
Joined: Sat Oct 09, 2010 8:38 pm
Location: Pompton Plains, NJ

Re: Sending ATC audio to the headset

Postby BonanzaDude » Thu Dec 12, 2013 3:34 pm

Keith Smith wrote:John,
Regarding the remote machine, it sounds like you had overlapping PTT assignments.

Keith,

I certainly did have that problem. Funny thing was that I changed my PTT switch to another key/button on Ventrilo and I was still having the problem. I think I will just keep it the way it is now. I still run FSInn remotely as I am able to keep the control panel on my laptop but use my FSX box for communications.

John
John P. Navara
zLAARTCC & PE I-11
PP ASEL-IA - 1967 V35 N480H
Complex, HP & Tailwheel endorsements
My YouTube Videos
http://www.twitch.tv/Sim_Dude
BonanzaDude
 
Posts: 202
Joined: Wed Jun 22, 2011 1:29 pm
Location: Tiffin, IA

Re: Sending ATC audio to the headset

Postby Keith Smith » Tue Jun 17, 2014 8:43 am

Original post updated. The new pilot client now allows you to specify the audio device.
Keith Smith
 
Posts: 9332
Joined: Sat Oct 09, 2010 8:38 pm
Location: Pompton Plains, NJ

Re: Sending ATC audio to the headset

Postby gavink42 » Tue Jun 17, 2014 10:06 am

Yes... yes... yes!!! Thank you so much!!! :D
- PP ASEL, instrument, complex, high performance
- Member AOPA, EAA, IMC Club, Piper Owner Society
- Cherokee 180C owner
gavink42
 
Posts: 171
Joined: Mon Apr 16, 2012 7:08 pm
Location: KMEM

Re: Sending ATC audio to the headset

Postby gwa_sandiego » Tue Jan 13, 2015 10:09 pm

OK,I'm running X-Plane 10 on a Mac. I also am trying to ATC to my headset, but it comes out the PC speaker. I have read the posts and set my Mac prefs to line out for the speaker. When I attempt to set my PE Audio preferences no mouse click will select any of the choices in the list and the choice is stuck at the top with "Airplay" selected.

Anyone else hit this bug?

thanks,

Gene
gwa_sandiego
 
Posts: 1
Joined: Tue Jan 13, 2015 10:04 pm

Re: Sending ATC audio to the headset

Postby Keith Smith » Wed Jan 14, 2015 6:42 am

First I've heard of it. I know we've covered this via the support helpdesk with you, but for those reading along here, I've suggested that he try removing his existing audio prefs file (VSProSound.ini in the PilotEdge/VSPro Resources folder) and see if he's able to select anything in the list after that. That listbox is a standard 3rd party widget, I haven't seen cases where an item couldn't be selected before.
Keith Smith
 
Posts: 9332
Joined: Sat Oct 09, 2010 8:38 pm
Location: Pompton Plains, NJ

Re: Sending ATC audio to the headset

Postby ChipDeMoss » Sun Oct 29, 2017 11:13 am

Keith - this problem has reared its ugly head again. Have been running mic and sound through aviation headset connected to the flightsounds usb box. Today, sound defaulted to system speaker, and when I pulled up the list in the PilotEdge preferences plugin to change it, I am unable to select the correct item. I can scroll up and down the list, but cannot select any of the items. I have deleted the VSProSound.ini file, which previously worked, but still no luck. Using X-Plane 11 on Windows 10 64 bit system. Any help you can supply would be greatly appreciated.

Chip
ChipDeMoss
 
Posts: 6
Joined: Mon Apr 24, 2017 8:19 pm

Re: Sending ATC audio to the headset

Postby Keith Smith » Mon Oct 30, 2017 7:50 am

Chip,

You can bypass this issue by selecting the audio device at the OS level instead of the plugin level. Have your speakers set as the 'Default Device', but have your USB device set as the 'Default COMMUNICATIONS Device' and that should do the trick.

Someone recently reported that they were unable to select the device from the PE preferences when xplane was running on a screen other than the primary desktop. I haven't been able to replicate that, though.
Keith Smith
 
Posts: 9332
Joined: Sat Oct 09, 2010 8:38 pm
Location: Pompton Plains, NJ

Re: Sending ATC audio to the headset

Postby ChipDeMoss » Mon Oct 30, 2017 9:46 am

Keith -used your suggestion in combination with deleting the vsprosound.ini file and was able to get comms re-established through the headset. Initially deleted the ini file and then set OS sound to headphones. Then when plugin came up, it defaulted to headphones. Then I went back and set OS system sound to external speaker for engine noise, but the plugin sound remained with the headphones.

Thanks,

Chip
ChipDeMoss
 
Posts: 6
Joined: Mon Apr 24, 2017 8:19 pm

Previous

Return to Flight Simulators and PE clients

Who is online

Users browsing this forum: No registered users and 1 guest