XP11.5 crashing with Big Sur

XP11.5 crashing with Big Sur

Postby MartyO » Thu Nov 26, 2020 9:52 pm

Hi,

I've posted this on Discord, but Kevin thought it might get some more exposure if I posted here as well.

I have been flying without a hitch on PE up until I upgraded to Mac OS Big Sur (11.0.1). Since the change, I am fine when I fly XP as a stand alone program but when I add the PE plugin, I'm crashing. This is usually happening after about 20 minutes or so of being connected to the network.

The log.text says "This application has crashed because of plugin" PilotEdge.

It appears that I can't upload a .txt file here , so let me know how I can get the log.txt files to you as well as the PIlotEdge_out.txt file to you.

Let me know if there is any other information that might be relevant that wold help in problem solving this issue.

Thanks in advance for your time!
MartyO
 
Posts: 4
Joined: Tue Jul 07, 2020 9:54 pm

Re: XP11.5 crashing with Big Sur

Postby Keith Smith » Fri Nov 27, 2020 9:17 am

The crash log is what we'd need. I'm going to have to try to get access to newer Mac with the latest OS to be able to debug properly, I suspect. If you can post the content of the crash log, that would be best as it will tell me which function within the code is causing the issue.
Keith Smith
 
Posts: 9908
Joined: Sat Oct 09, 2010 8:38 pm
Location: Pompton Plains, NJ

Re: XP11.5 crashing with Big Sur

Postby MartyO » Fri Nov 27, 2020 5:08 pm

Hi Keith,

I started XP11 and connected to the network and let if fail on it's own. The only thing you'll see on your end is me connecting to the network. I didn't do anything inside the cockpit, just connected and let it run unit the failure point. Apple provided me with a "problem report for X-Plane 10.5043" so I hope this is what you are looking for. Let me know if there are other pieces to the puzzle that would help you as well.

Again, I didn't change any aspects of the configuration with the exception of migrating to 11.0.1. Everything (including PE) worked fine when I was at 10.5.whatever it was.

Thanks for addressing this issue.
Attachments
Log.docx
(37.48 KiB) Downloaded 18 times
Problem Report for X-Plane 11.50r3.docx
(50.12 KiB) Downloaded 23 times
MartyO
 
Posts: 4
Joined: Tue Jul 07, 2020 9:54 pm

Re: XP11.5 crashing with Big Sur

Postby Keith Smith » Sat Nov 28, 2020 7:58 am

Marty,

Disable your traffic relay to ForeFlight for now. That's where the issue is occuring according to this stack trace (rename the VSProTrafficRelay.ini back to .bak)
Keith Smith
 
Posts: 9908
Joined: Sat Oct 09, 2010 8:38 pm
Location: Pompton Plains, NJ

Re: XP11.5 crashing with Big Sur

Postby MartyO » Sat Nov 28, 2020 8:37 am

Hi Keith,

Thanks for looking into this. I've done the rename and am connected to PE and just sitting at KPAE. I'll let it run and see if that did the trick.

Marty
MartyO
 
Posts: 4
Joined: Tue Jul 07, 2020 9:54 pm

Re: XP11.5 crashing with Big Sur

Postby MartyO » Sat Nov 28, 2020 11:47 am

Hi Keith,

Okay, looks like that did the trick. I just sat at KPAE for a good 1:45 and it stayed connected. I then signed out and signed back in and flew from KYKM to KOLM without any issues.

So is the only the thing that changed, at this point, is that I can't see PE traffic on Foreflight? If you could let me know, I'd appreciate it.

Thanks for the quick response to this issue!

Marty
MartyO
 
Posts: 4
Joined: Tue Jul 07, 2020 9:54 pm

Re: XP11.5 crashing with Big Sur

Postby Keith Smith » Sat Nov 28, 2020 11:51 am

Marty,

Yes, the VSProTrafficRelay.ini file is used exclusively to relay traffic to ForeFlight So, that's the only functionality you've disabled.
Keith Smith
 
Posts: 9908
Joined: Sat Oct 09, 2010 8:38 pm
Location: Pompton Plains, NJ

Re: XP11.5 crashing with Big Sur

Postby lebovitzn » Fri Feb 26, 2021 7:41 am

Hi,

Just wondering as this thread hasn't been updated in 3 months.
Is there a fix to the ForeFlight connection crash for Big Sur?
Or is there an ETA for the fix?

Thanks!!!
lebovitzn
 
Posts: 1
Joined: Thu Feb 25, 2021 1:25 pm

Re: XP11.5 crashing with Big Sur

Postby Keith Smith » Fri Feb 26, 2021 8:04 am

It'll be at least a few weeks before I can look, I need to get access to a Big Sur test environment to try to replicate.
Keith Smith
 
Posts: 9908
Joined: Sat Oct 09, 2010 8:38 pm
Location: Pompton Plains, NJ


Return to X-Plane

Who is online

Users browsing this forum: No registered users and 3 guests

cron