unable to run plugin

unable to run plugin

Postby mark_l » Wed Aug 29, 2018 5:43 pm

I've got linux 16.10 and xplane 11.25

after putting the plugin in the plugin folder and starting xplane, the pilotedge plugin does not appear in the dropdown list

this appears in the xplane log.txt:


dlerror:libpng12.so.0: cannot open shared object file: No such file or directory
dlerror:/home/mark/X-Plane 11/Resources/plugins/PilotEdge/lin.xpl: wrong ELF class: ELFCLASS32
mark_l
 
Posts: 1
Joined: Wed Aug 29, 2018 5:33 pm

Re: unable to run plugin

Postby Keith Smith » Thu Aug 30, 2018 9:00 am

Answered via tech support, but will answer here in case others might have the issue.

Your system is missing a required library (libpng12). Google that term and you'll see many links for where to obtain the library.

The second error can be ignored...that's xplane attempting to load the a version of the plugin from a legacy location having failed to load it from the preferred 64-bit location. The version that it's finding in the legacy location is the 32-bit version of the plugin, hence the error message. Fixing the first error will allow the 64-bit plugin to load, after which it won't attempt to load from the legacy location at all.
Keith Smith
 
Posts: 9563
Joined: Sat Oct 09, 2010 8:38 pm
Location: Pompton Plains, NJ

Re: unable to run plugin

Postby nima » Mon Apr 08, 2019 12:22 am

Hello PilotEdge support,

I ran into the same problem. The libpng library has been installed, but the version is different.
Error :
Code: Select all
dlerror:libpng12.so.0: cannot open shared object file: No such file or directory
dlerror:/home/nima/X-Plane 11/Resources/plugins/PilotEdge/lin.xpl: wrong ELF class: ELFCLASS32


The default libpng package which is shipped with Debian Buster is libpng16.
OS: Debian Buster
Xplane : 11.32r2
PilotEdge plugin version: the latest available zip file on site ( 1 March 2019 ).


Can you please advise how we can resolve this issue ? or we should wait until new version of PilotEdge ?
nima
 
Posts: 2
Joined: Mon Apr 08, 2019 12:15 am

Re: unable to run plugin

Postby nima » Mon Apr 08, 2019 12:50 am

I managed to resolve the issue. Finally I had to install the libpng12 manually and now the pilotedge is available in plugin list drop-down.

For reference, I installed the package from below link.
Debian package : https://www.google.com/url?q=https%3A%2 ... VzoU5caVEw



Thans
nima
 
Posts: 2
Joined: Mon Apr 08, 2019 12:15 am


Return to X-Plane

Who is online

Users browsing this forum: Bing [Bot] and 2 guests